В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nataklmnv
nataklmnv
27.12.2021 21:30 •  Информатика

Составить блок схему и написать программу которая находит сумму цифр четного четырехзначного числа либо произведение нечетного четырехзначного числа

Ответ:
guardrus
guardrus
07.10.2020 18:30
Программа:
program abc;
var x,s,p:integer;
begin
writeln('Введите четырехзначное число');
readln(x);
if (x mod 2)=0 then
begin
  s:=(x mod 10)+(x div 10 mod 10)+(x div 100 mod 10)+x div 1000;
  writeln('s=',s);
  end
else
  begin
  p:=(x mod 10)*(x div 10 mod 10)*(x div 100 mod 10)*x div 1000;
  writeln('p=',p);
  end;
end.
Блок-схема

Составить блок схему и написать программу которая находит сумму цифр четного четырехзначного числа л
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?