В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
arinalapshakova
arinalapshakova
03.05.2023 18:53 •  Информатика

Неlp. напишите программу по поиску наименьшего элемента в массиве (массив заполнить случайными числами из диапазона от -5 до 44)

Ответ:
каринп4
каринп4
07.10.2020 18:30
// PascalABC.NET 3.3, сборка 1623 от 16.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-5,44); a.Println;
  Writeln('Min=',a.Min)
end.

Пример
n= 13
18 2 33 43 16 28 19 15 31 5 15 -3 20
Min=-3
0,0(0 оценок)
Ответ:
Ainur0529
Ainur0529
07.10.2020 18:30
//Написано на PascalABCCompiler.Core v3.3.0.1540 (16.09.2017)
var
    arr: array[1..20] of integer;
    m: integer := 45;
begin
    for var k := 1 to 20 do
    begin
        arr[k] := random(49) - 5;
        if arr[k] < m then m := arr[k];
    end;
    write('Исходный массив: ');
    for var k := 1 to 20 do
    begin
        write(arr[k], ' ');
    end;
    writeln;
    write('Наименьшее число массива: ', m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?