В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kholmatova002
kholmatova002
27.01.2023 11:22 •  Информатика

40б! составить программу которая запрашивает значение переменной x, номер арифметического действия и в зависимости от номера действия определяет y. x(в квадрате), если n=1 cos(x), если n=2 y= sin(x), если n=3 ixi, если n=4

Ответ:
valeria02042004
valeria02042004
21.08.2020 09:18
Varn: real;beginwriteln('Введите значение n: ');readln(n);if n=1 then writeln('n= ',sqr(n))elseif n=2 then writeln('n= ',cos(n))else if n=3 then writeln('n= ',sin(n))elseif n=4 then writeln('n= ',abs(n));end.
0,0(0 оценок)
Ответ:
NastyaBay2710
NastyaBay2710
21.08.2020 09:18
Var
x:real;
n:integer;
begin
Write('Введите x -> ');
Readln(x);
Write('Введите номер действия(1..4) - > ');
readln(n);
case n of
  1: Writeln('y = ', x*x);
  2: Writeln('y = ', cos(x));
  3: Writeln('y = ', sin(x));
  4: Writeln('y = ', abs(x));
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?