В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ivolapseb
ivolapseb
21.02.2021 06:03 •  Информатика

Решать через паскаль! даны числа n и m. создайте массив a[n][m] и заполните его змейкой (см. пример). входные данные программа получает на вход два числа n и m. выходные данные программа должна вывести полученный массив, отводя на вывод каждого числа ровно 3 символа. примеры входные данные 4 10 выходные данные 0 1 2 3 4 5 6 7 8 9 19 18 17 16 15 14 13 12 11 10 20 21 22 23 24 25 26 27 28 29 39 38 37 36 35 34 33 32 31 30 я написала программу всё правильно ,но она начинается не с нуля исправьте ошибку: var a: array[1..100,1..100] of integer; i,j,n,m: integer; begin readln(n,m); for i: =1 to n do begin for j: =1 to m do begin if i mod 2=1 then a[i,j]: =(i-1)*m+j else a[i,j]: =i*m-j+1; write(a[i,j]: 3); end; writeln; end; end. 4 10 1 2 3 4 5 6 7 8 9 10 20 19 18 17 16 15 14 13 12 11 21 22 23 24 25 26 27 28 29 30 40 39 38 37 36 35 34 33 32 31

Ответ:
ivanivanov2007r
ivanivanov2007r
16.08.2020 16:24
Попробуй начать цикл с i не с 1, а с 0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?