Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Vikula2404
22.01.2020 04:42 •
Информатика
Напишите программу [на pascal], которая вычисляет минимальное из трёх введённых чисел. используйте функцию.
Ответ:
idrisovbulat
16.08.2020 16:18
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
function Min3(a,b,c:real):=Min(a,Min(b,c));
begin
var (x,y,z):=ReadReal3('Введите три числа:');
Writeln('Минимальное: ',Min3(x,y,z))
end.
Пример
Введите три числа: 3.18 -2 5.7
Минимальное: -2
0,0
(0 оценок)
Ответ:
пвиопп
16.08.2020 16:18
function min(x,y:integer):integer;
begin
if x<y then min:=x else min:=y;
end;
var a,b,c:integer;
begin
readln(a,b,c);
writeln('min = ',min(min(a,b),c));
end.
Пример:
8 2 5
min = 2
0,0
(0 оценок)
Популярные вопросы: Информатика
ArtemyEvergreenIV
07.08.2021 20:37
Составить программу которая выводит на экран последнюю цифру целого числа...
TanushaGuda
24.10.2020 05:24
Какой самый простой язык программирования? ...
kostaKOSTAkosta
03.02.2022 17:26
- Гиперсілтеме дегеніміз не?- Гиперсілтеме нені алмастырады?- Гиперсілтеменің қандай типтерін білесіңдер? Олардыңқайсысы күрделі?- Гиперсілтеме қосу батырмаларының қандай түрлерін...
RitaAvakyan1
08.04.2020 03:07
Егэ информатика 23 сколько существует различных наборов значений логических переменных x1, x2, x8, y1, y2, y8, которые удовлетворяют всем перечисленным ниже условиям? (x1→x2) /\...
Юля5900274
13.12.2021 11:47
ответы на вопросы по биологии 8 класс действие слюны на крахмал . первый вопрос : что было субстратом, а что - ферментом, когда вы писали букву на бинте? второй вопрос: могла ли...
Лчший
13.12.2021 11:47
Вычеркните лишнее имя: кучум,ермак,андрей курбский,срогановы,иван кольцо...
Pro100iraa
13.12.2021 11:47
1) уменьши в 6 раз 12кг 420г; 6 куб . см 414 куб.мм 2) уменьши в 32 раза 32кв.см 640 кв.мм; 1 мин 36 с. !...
Йорик336
13.12.2021 11:47
Выполните деление с остатком. 239: 10 270: 20 260: 50 14 780: 100 6 600: 900 2 000: 300 123 917: 1 000 58 000: 8000 19 000: 6 000...
nastiasteinoxz34d
13.12.2021 11:47
Во сколько раз сопротивление нихромовой проволоки длиной 4 м больше сопротивления никелевой проволоки такой же длины и такого же сечения?...
Dinara260803
13.12.2021 11:47
На пруду плавали белые и серые утки. белые утки составляли 4 пятых всех уток. сколько всего уток плавало на пруду, если белых уток было 40?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
function Min3(a,b,c:real):=Min(a,Min(b,c));
begin
var (x,y,z):=ReadReal3('Введите три числа:');
Writeln('Минимальное: ',Min3(x,y,z))
end.
Пример
Введите три числа: 3.18 -2 5.7
Минимальное: -2
begin
if x<y then min:=x else min:=y;
end;
var a,b,c:integer;
begin
readln(a,b,c);
writeln('min = ',min(min(a,b),c));
end.
Пример:
8 2 5
min = 2