В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
safievd6Димас
safievd6Димас
16.07.2021 07:07 •  Информатика

9. написать программу вычисления функции у: у=sqrt(х+5).если x> 0. у= sqrt(5+х), если x< =0 в случае отрицательного подкоренного выражения выводится надпись "останов" и программа заканчивается.

Ответ:
bileskayilona
bileskayilona
07.10.2020 16:07
Программа вкратце.
Если посещал уроки то сможешь ее написать чтоб работала.
В условии задачи ошибка, наверное вместо - написал плюс.
y = sqrt(х+5). если x>0.
пусть здесь будет так: у= sqrt(5-х). если x<0

Program radical;
var x,y:integer;
Begin
readln(x);
if ((x+5) >= 0) and ((5-х) >=0)) then begin
   { проверка чтобы не-было меньше нуля }
    if (x>0) then 
       y = sqrt(x+5);
    else if (x<0) then 
       y = sqrt(5-x);
    writeln('результат=', y); 

   end
else 
    writeln("нельзя извлечь корень из отрицательного числа");

readln();

End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?