В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
annaarzama
annaarzama
31.07.2022 20:23 •  Информатика

Нужна по программированию. нужна пятёрка и я получу за четверть пять, . напишите программу в паскале. имеется одна коробка со сторонами а б с(вводятся с клавиатуры), ещё есть 1 коробка со сторонами x z t(вводятся с клавиатуры). надо ответить влезит ли первая коробка во вторую если коробки можно вращать.

Ответ:
Karlik777
Karlik777
07.10.2020 15:26
Var a,b,c,x,z,t,k: integer;
begin
  write('a b c через пробел:  ');  readln(a,b,c);
  write('x z t через пробел:  ');  readln(x,z,t);
  if a>b then swap(a,b);
  if b>c then swap(b,c);
  if b<a then swap(a,b);
  if x>z then swap(x,z);
  if z>t then swap(z,t);
  if z<x then swap(x,z);  
  k:=0;
  if a>=x then 
     if (b>=z) and (c>=t) then k:=1;
  if (a<=x) then
     if (b<=z) and (c<=t) then k:=1;
  if k=1 then writeln('да')
  else writeln('нет');
end.

a b c через пробел:  10 7 3
x z t через пробел:  3 5 9
да

a b c через пробел:  8 5 7
x z t через пробел:  9 7 4
нет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?