В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
авлвк5
авлвк5
24.09.2022 10:50 •  Информатика

Написать программу в паскале позволяющую найти среднее арифметическое элементов массива состоящего из 10 чисел которые превышают число c.

Ответ:
Frapado
Frapado
26.08.2020 20:52
1.
begin
 var a:=ArrRandom(10,1,50); a.Println;
 var c:=ReadInteger('c = ');
 var s:=a.Where(x->x>c);
 if s.Count>0 then
 writeln('Среднее арифметическое элементов > ',c,' = ',s.Average)
 else writeln('В массиве нет искомых элементов');
end.

Пример:
8 2 22 16 24 34 29 16 1 26
c =  50
В массиве нет искомых элементов

2.
const n=10;
var a:array[1..n] of integer;
c,i,s,k:integer;
begin
Randomize;
for i:=1 to n do begin
 a[i]:=random(51);
 write(a[i],' ');
 end;
writeln;
write('c = ');
readln(c);
s:=0; k:=0;
for i:=1 to n do
 if a[i]>c then begin s:=s+a[i]; k:=k+1; end;
if k>0 then writeln('Среднее арифметическое элементов > ',c,' = ',s/k:5:2)
else writeln('В массиве нет искомых элементов');
end.

Пример:
39 38 43 25 45 16 16 12 35 16
c = 40
Среднее арифметическое элементов > 40 = 44.00
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?