В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
лунтик73
лунтик73
11.12.2020 01:15 •  Информатика

Написать программу на паскале которая запрашивает трёхзначное число, затем с функций div mod разделяет число на цифры и проверяет имеются ли в введенном числе цифра "5". если да, то печатает "имеется" иначе "не имеется

Ответ:
Albina0981
Albina0981
07.10.2020 14:14
Var N, k, y: integer;
begin
  write('Введите число: ');
  readln(N);
  k := 0;
  repeat
    y := N mod 10;
    if y = 5 then k := k + 1;
    N := N div 10;
  until N = 0;
  if k <> 0 then writeln('Имеется')
  else writeln('Не имеется')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?