В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vladt12092002
vladt12092002
19.03.2023 01:58 •  Информатика

Составьте программу,которая определяет какое из трех введенных с клавиатуры чисел является средним.если среди чисел есть равные,то вывести сообщение"ошибка"

Ответ:
mamka18
mamka18
07.10.2020 13:24
Var a,b,c: integer;
begin
  write('числа: '); readln(a,b,c);
  if a>b then swap(b,c);
  if c<a then swap(a,c);
  if b>c then swap(b,c);
  if (a=b) or (b=c) then writeln('ошибка')
  else writeln('среднее: ',b);
end.

числа: 9 17 8
среднее: 9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?