В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ggf6fr
ggf6fr
07.07.2021 00:56 •  Информатика

Вмассив с клавиатуры вводятся результаты соревнований по многоборью 7 спортсменов (значениея результатов от 1000 до 2000 ). составить программу которая находит номер и результат победителя

Ответ:
спеш
спеш
07.10.2020 13:22
Var
  A: array[1..7] of integer;
  i: byte;
  Max, MaxInd: integer;
begin
writeln('Заполнение массива. Вводите числа от 1000 до 2000.');
for i := 1 to 7 do
begin
  write('A[',i,']=');
  readln(A[i]);
  if A[i] > Max then
  begin
    Max := A[i];
    MaxInd := i;
  end;
end;
writeln;
writeln('№ победителя ', MaxInd, ' результат = ', Max, ' .' );
end.

Вмассив с клавиатуры вводятся результаты соревнований по многоборью 7 спортсменов (значениея результ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?