В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
BeemayaS
BeemayaS
01.12.2020 15:10 •  Информатика

Решить "составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапозоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями

Ответ:
kravcovleonid5
kravcovleonid5
10.09.2020 08:26
Program NekitZor;
const
n=10;
var a:array[1..n] of integer;
i,sum,sam:integer;
begin
randomize;
for i:=1 to n do
a[i]:=random(99)-25;
for i:=1 to n do write(a[i],'   ');
begin
sum:=0;
for i:=1 to n do
if a[i] mod 2 = 0 then sum:=sum+a[i]
else sam:=sam+a[i];
end;
writeln();
writeln('Сумма четных елементов = ',sum);
writeln('Сумма не четных елементов=',sam);
end.
Решить составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапозоне
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?