В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
лулы
лулы
03.05.2023 13:53 •  Информатика

Напишите легкую программу на паскале . напишите программу которая в последовательности нат. чисел определяет сумму чисел оканчивающихся на 5. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число оканчивающейся на 5. количество чисел не превышает 100. введённые числе по модулю не превышают 300. программа должна вывести одно число: сумму чисел оканчивающихся на 5. входные данные 3 15 25 24 выходные данные 40

Ответ:
nikita140982ee
nikita140982ee
07.10.2020 12:57
Program suma;
Var a:array [1..100] of integer;
    k, i, sum:integer;
begin
  write('Введите число: ');
  read(k);
  for i:=1 to k do read(a[i]);
  for i:=1 to k do
    if a[i] mod 10 = 5 then
      sum:=sum + a[i];
 
  write('Сумма равна: ', sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?