В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
stalkerdanil111
stalkerdanil111
14.08.2022 17:08 •  Информатика

Написать программу на с программа, которая переводит заданое число из восьмиричной системы в пятиричную

Ответ:
ulzhalgasamangEldy
ulzhalgasamangEldy
07.10.2020 12:57
Замечание: контроль правильности ввода не выполняется.
#include <stdio.h>

int main(void) {
  int a_8, a_10, a_5, b, c;
  printf("Введите число в восьмеричной системе счисления: ");
  scanf("%d",&a_8);
  b = a_8;
  a_10 = 0; c = 1;
  while (b>0) {
    a_10 += c*(b % 10);
    c *= 8;
    b /= 10;
  }
  b = a_10;
  a_5 = 0; c = 1;
  while (b>0) {
    a_5 += c*(b % 5);
    c *= 10;
    b /= 5;
  }
  printf("%d(8) = %d(10) = %d(5)",a_8,a_10,a_5);
  return 0;
}

Пример:
Введите число в восьмеричной системе счисления: 2014
2014(8) = 1036(10) = 13121(5)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?