В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ddbbqq
ddbbqq
26.11.2020 17:22 •  Информатика

Написать программу: дано трехзначное число. найти сумму цифр числа и определить является ли она четным числом.

Ответ:
antonshv313p012l5
antonshv313p012l5
26.08.2020 20:27
//Pascal
var a, sum: integer;
begin
write('Введите число:'); readln(a);
  while a <> 0 do
  begin
    sum := sum + (a mod 10);
    a := a div 10;
  end;
  writeln('Сумма цифр = ', sum);
  if sum mod 2 = 0 then writeln('Сумма четная')
  else writeln('Сумма нечетная')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?