В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
steshagoncharov
steshagoncharov
01.06.2022 10:41 •  Информатика

Написать программу, которая определяет, каким днем (рабочий день, суббота, воскресенье) является введенный номер дня недели. в теранарном операторе, как делать?

Ответ:
playertony200
playertony200
07.10.2020 11:42
Не "теранарный", а тернарный оператор.
Есть во многих языках программирования, зря не указали, какой Вам надо.

// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('День недели (1- Пн, 2- Вт, ... 7- Вс:');
  Writeln(n<6?'Рабочий день':n=6?'Суббота':'Воскресенье')
end.

Примеры (предполагается без проверки корректность ввода)
День недели (1- Пн, 2- Вт, ... 7- Вс: 4
Рабочий день

День недели (1- Пн, 2- Вт, ... 7- Вс: 6
Суббота

День недели (1- Пн, 2- Вт, ... 7- Вс: 7
Воскресенье
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?