В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
VladProstoboy
VladProstoboy
27.04.2021 03:19 •  Информатика

Написать программу, которая показывает пользователю на экран три страны и предлагает выбрать одну. после того, как пользователь выберет страну, программа показывает три города (для какой-то страны может показать правильно, для какой-то - нет) и спрашивает пользователя, относятся ли эти города к выбранной им стране. после ответа пользователя, программа сообщает ему, правильно он ответил, или нет на с++

Ответ:
chizhvlad2003p017q2
chizhvlad2003p017q2
07.10.2020 11:19
#include <iostream>
using namespace std;

int main() {
 setlocale(LC_ALL, "Russian");
 int n,k;
 string s[3][3]=
 {{"1 - Перу","2 - Тайланд","3 - Венгрия"},
 {"Лима, Арекипа, Куско", "Паттайя, Чиангмай, Сиемреап", "Сентендре, Секешфехервар, Веспрем"},
 {"Все эти замечательные города находятся в Перу",
 "Паттайя и Чиангмай находятся в Тайланде, но Сиемреап - это Камбоджа",
 "Все перечисленные города с непростыми названиями находятся в Венгрии"}};
 cout << "Выбери страну по номеру: " << s[0][0] << " " << s[0][1] << " " << s[0][2] << "\n";
 cin >> n;
 cout << "Относятся ли перечисленные ниже города к выбранной стране?\n";
 cout << s[1][n-1] << "\n";
 cout << "Да-1, Нет-0 ";
 cin >> k;
 if ((n==1)&&(k==1)||(n==2)&&(k==0)||(n==3)&&(k==1)) cout << "Вы правы! \n";
 else cout << "Вы ошиблись.\n";
 cout << s[2][n-1];
 return 0;
}

Написать программу, которая показывает пользователю на экран три страны и предлагает выбрать одну. п
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?