Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Arthas1212523
04.07.2021 22:50 •
Информатика
Pascal abc составить программу для нахождения s дано натуральное число n. найти сумму s=1- 1/5 + 1/9 - 1/+ (n-слагаемых) !
Ответ:
danilyakimov1
07.10.2020 11:12
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
Writeln(Range(0,n-1).Select(i->1/(i.IsEven?4*i+1:-(4*i+1))).Sum)
end.
Пример
n= 13
0.876761945581588
для Pascal ABC (проверить негде, проект закрыт в 2004 году)
var
i,n,z:integer;
x,s:real;
begin
Write('n='); Read(n);
s:=0; z:=1;
for i:=0 to n-1 do begin
x:=1/(4*i+1);
s:=s+x*z;
z:=-z
end;
Writeln(s)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
e12esa
20.04.2022 19:53
Выберите верные утверждения. * Символ – это минимальный единица размера шрифта в тексте. Цвет подложки символа – это цвет прямоугольной области, отводимой под каждый символ, не занятой...
amelkonatasha
14.12.2021 13:23
Тестовые во по информатике для учащихся 6-ых классов.СОР за 4 четверть.1. Примечание, текст которого отделяют знаком сноски от основного документа внизу страницы или в конце текста:a)...
Kisha12345
12.11.2020 03:12
Катя была на соревнованиях по регби. Для каждой команды, участвовавшей в турнире Катя сделала один пост в Instagram с фотографией этой команды. Каждая команда сыграла с каждой. Из...
Rusynyk
02.10.2021 04:53
100 ів. написати программу на мові c++...
ivettapopova045
30.09.2020 02:52
Я тебя, 4) чтобы x+2y разделить на 3xy, надо записать выражение а) x+2*y/3*x*y; б) (x+2*y)/3*x*y; в) (x+2y)/(3xy); г) (x+2*y)/(3*x*y)....
artemka222288
26.11.2020 02:52
Амплитуда коливань струни 1 мм а чистота 1000 гц який шлях пройде точка на струни за 0.2с?...
Sania24sania
26.11.2020 02:52
Площадь боковой поверхности цилиндра равна 60п а диагональ осевого сечения равна 13 найдите радиус...
sakulich05
26.11.2020 02:52
Вычислите молярную массу газа , если масса 200 мл его ( ну ) равна 0,232 r ....
деня1990
26.11.2020 02:52
Радіус кола, вписаного в основу правильної піраміди , дорівнює 5√3 см. знайдіть кут нахилу бічної грані піраміди до основи піраміди , якщо висота піраміди дорівнює 15 см....
04812
26.11.2020 02:52
Past simple или past continuous: правило, примеры, когда упод-ся, сигналы и тд (подалуйста объясните по человечески)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
Writeln(Range(0,n-1).Select(i->1/(i.IsEven?4*i+1:-(4*i+1))).Sum)
end.
Пример
n= 13
0.876761945581588
для Pascal ABC (проверить негде, проект закрыт в 2004 году)
var
i,n,z:integer;
x,s:real;
begin
Write('n='); Read(n);
s:=0; z:=1;
for i:=0 to n-1 do begin
x:=1/(4*i+1);
s:=s+x*z;
z:=-z
end;
Writeln(s)
end.