В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mishazhidkov2
mishazhidkov2
30.09.2022 18:06 •  Информатика

Написать программу на паскале. найти корень уровнения f(x)=ln⁡(.5/x^2)=0 в интервале [ 0.1 ; 1.5 ] x=1,327_864

Ответ:
kiryazhigulski
kiryazhigulski
07.10.2020 11:04
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

uses NumLibABC;

begin
  var oL:=new Zeroin(x->Ln(x)-(0.5/Sqr(x)),1e-8);
  Writeln('x=',oL.Value(0.1,1.5):0:8)
end.

Пример с точностью 10⁻⁸
x=1.32786401

Замечание: Исходный текст класса Zeroin в составе библиотеки численных методов NumLibABC находится в стандартной поставке PascalABC.NET
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?