В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ирина1853
ирина1853
10.09.2020 06:37 •  Информатика

Вмассиве хранится информация о среднедневной температуре за неделю в декабре. составьте программу, которая подсчитает, сколько дней за неделю было с положительной температурой, сколько дней было с отрицательной и нулевой температурой. найдите максимальную температуру за неделю. массив вводится с клавиатуры.

Ответ:
890605
890605
07.10.2020 10:35
//PascalABC.NET версия 3.3.1590 от 03.12.17
//Если программа не запускается, то обновите версию
begin
    var a := ReadArrReal('Введите температуры за неделю', 7);
    Writeln('Дней за неделю было с положительной температурой = ', a.Count(x -> x > 0));
    Writeln('Дней за неделю было с отрицательной температурой = ', a.Count(x -> x < 0));
    Writeln('Дней за неделю было с нулевой температурой = ', a.Count(x -> x = 0));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?