В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
olga195888
olga195888
06.02.2023 01:33 •  Информатика

Написать программу : дан двумерный массив а, состоящий из n элементов. найти минимальный из элементов этого массива с нечетными индексами и максимальный из элементов с четными индексами.

Ответ:
korostin2004
korostin2004
04.08.2020 06:58
Var
  a: array [1..100] of integer;

begin
  var N := ReadInteger;
  var mmax := Integer.MinValue;
  var mmin := integer.MaxValue;
  for var i := 1 to N do
  begin
    readln(a[i]);
    if (i mod 2 <> 0) and(a[i] < mmin) then mmin := a[i];
    if (i mod 2 = 0) and (a[i] > mmax) then mmax := a[i]
  end;
  writeln('Минимальный элемент массива с нечетным индексом: ', mmin);
  writeln('Максимальный элемент массива с четным индексом: ', mmax)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?