В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составить программу для данного условия: вычисление суммы только положительных чисел из последовательно введенных чисел ( остановить обработку при 100.0) . в паскале

Ответ:
Alevtinka28
Alevtinka28
07.10.2020 10:07
Var a,s:real;
begin
s:=0;
repeat
readln(a);
if a>0 then s:=s+a;
until s>=100;
writeln('s = ',s:5:1);
end.

Пример:
45
-84
12
30
-30
53
s = 140.0
Составить программу для данного условия: вычисление суммы только положительных чисел из последовател
0,0(0 оценок)
Ответ:
alice108
alice108
07.10.2020 10:07
Вычисление суммы только положительных чисел из последовательно введенных чисел ( остановить обработку при 100.0) 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?