В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mahotinvasili
mahotinvasili
28.08.2020 21:58 •  Информатика

Составить программу формирования массива из 50 элементов, в которой используется признак р, в зависимости от значения которого реализовывался бы один из массива: при р= -1 с генератора случайных чисел, при р=0 с формулы а[i] = i +101, при р=1 с клавиатуры. сделать вывод сформированного массива на экран.

Ответ:
astimorget
astimorget
07.10.2020 10:06
Const n=50;
var a: array[1..n] of integer; 
  p,i: integer;
begin
write('p (-1,0,1) = ');
readln(p);
case p of
 1: for i:=1 to n do a[i]:=random(100);
 0: for i:=1 to n do a[i]:=i+101;
-1: begin for i:=1 to n do read(a[i]); readln; end;
    end; 
writeln;
writeln('Исходный массив:');
for i:=1 to n do write(a[i],' ');
writeln;
end.

Пример (для n=5):
p (-1,0,1) = 0
Исходный массив:
102 103 104 105 106
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?