В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
алекс818
алекс818
24.04.2023 11:26 •  Информатика

Дан массив 20 целых, диапазон от -15 до +20 найти мин элемент и сумму кратных 3( написать программу pascal )

Ответ:
Josoy
Josoy
07.10.2020 09:48
Program n1;
const n=20;
var a: array [1..n] of integer;
i,min,sum:integer;
begin
randomize;
sum:=0;
write('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(36)-15;
write(a[i],' ');
if a[i] mod 3=0 then sum:=sum+a[i];
end;
writeln;
min:=a[1];
for i:=1 to n do if min>a[i] then min:=a[i];
writeln('минимальный элемент:', min);
writeln('сумма кратных трем: ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?