В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Ввести одномерный массив из 13 элементов. определить сумму элементов, которые при умножении на 4 значение большее чем при возведении в квадрат. напишите программу, .

Ответ:
дарханнысанов
дарханнысанов
07.10.2020 09:45
Program n1;
const n=13;
var a: array [1..n] of integer;
i,sum:integer;
begin
randomize;
sum:=0;
write('исходный массив: ');
for i:=1 to n do
begin
a[i]:=random(50);
write(a[i],' ');
if a[i]*4>a[i]*a[i] then sum:=sum+a[i];
end;
writeln;
write('искомая сумма: ',sum);
end.
0,0(0 оценок)
Ответ:
tur5
tur5
07.10.2020 09:45
Const
  CSize = 13;

var
  m: array[1..CSize] of integer;
  sum: integer;

begin
  sum := 0;
  for var i := 1 to CSize do
  begin
    read(m[i]);
    if (m[i] * 4) > (sqr(m[i])) then sum := sum + m[i];
  end;
  write(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?