Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
sabina300
02.06.2020 18:17 •
Информатика
Создайте программу в паскале, которая будет выводить на экран числовой ряд из 10 элементов, элементы в этой числовой последовательности чередуются по принципу: положительный, отрицательный. работает так: окно вывода: 1 -2 3 -4 5 -6 7 -8 9 -10
Ответ:
ushelemet
26.08.2020 19:29
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
SeqGen(10,i->i.IsEven?i+1:-(i+1)).Println
end.
Результат
1 -2 3 -4 5 -6 7 -8 9 -10
0,0
(0 оценок)
Ответ:
elinatyul
26.08.2020 19:29
//Pascal
var i: integer;
begin
for i := 1 to 10 do
if i mod 2 = 0 then write(i-(i+i), ' ')
else write(i, ' ');
writeln; readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
alinnnkaaa
01.06.2023 13:52
Сегодня на уроке информатики изучали маски файлов маской называется строка-шаблон, знак вопроса в записи которой соответствует любому одному символу, а звездочка (*) соответствует...
7Оля8
03.04.2020 12:02
Написать программу в паскале и составить алгоритм. вводится число х, определить нечетное оно и кратно ли 7. вывести сообщение на экран....
fistahka336
24.07.2020 18:02
Шығып, кестені толтырыңдар. ларды қарапМысалПрограммалық қамтамаПрограммалау жүйесіМәтіндік редакторГрафикалық редакторПрезентация редакторыЭлектронды кестелерЭлектронды оқу...
Клубничка0987654322
30.04.2021 06:56
хоть с чем то Ввести два целых числа, найти наибольшее и наименьшее из них. Пример: Введите два целых числа: 1 5 Наибольшее число 5 Наименьшее число 1 «4»: Ввести пять чисел...
SHILW
05.05.2020 18:30
Какая вкладкаявляется первой в окне программы microsoft word 2007?...
рустамммм
05.05.2020 18:30
Даны 3 стороны треугольника, составить программу в которой нужно определить равносторонний ли треугольник, если равносторонний, то вывести на экран сообщение треугольник - равносторонний...
ivan70region
24.12.2022 16:04
Найдите значение выражения 8a (4-26)+16 a /b при a=12 b=4,3...
Crazs
24.12.2022 16:04
Профессии, в которых нужны знания о бактериях...
superbogdanova
24.12.2022 16:04
Написать собщения о традиции и обычай мира...
vadik46
24.12.2022 16:04
Запишите в виде степени произведения: 1) 8* 8*8;...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
SeqGen(10,i->i.IsEven?i+1:-(i+1)).Println
end.
Результат
1 -2 3 -4 5 -6 7 -8 9 -10
var i: integer;
begin
for i := 1 to 10 do
if i mod 2 = 0 then write(i-(i+i), ' ')
else write(i, ' ');
writeln; readln;
end.