В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
southpaw40
southpaw40
23.01.2023 02:43 •  Информатика

Написать программу на с сформировать одномерный массив из 15 вещественных элементов, используя датчик случайных чисел, вычислить: произведение отрицательных элементов массива и сумму положительных элементов массива, расположенных до максимального элемента.

Ответ:
генетика2
генетика2
07.10.2020 09:10
#include "stdafx.h"
#include <iostream>
#include<ctime>
using namespace std;
int main()
{
setlocale(LC_ALL, "ru");
srand(time(NULL));
 const int SIZE = 11;
 int arr[SIZE];
const int SIZE2 = 1;
int arr2[SIZE2]{};
 int arr3[SIZE2]{};
 for (int i = 0,j=0,d=0; i < SIZE; i++)
{ arr[i] = rand() % 51-25;
 if (arr[i] < 0) { arr2[j] = arr2[j] + arr[i]; }
 if (arr[i] > 0) { arr3[d]= arr3[d]+ arr[i]; }
 if (i == 10)
 { cout << "Сумма отрицательных элементов массива = " << arr2[j] << endl;
  cout << "Сумма положительных элементов массива = " << arr3[d] << endl; }
}
 system("pause");
return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?