В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dashvali
dashvali
16.05.2020 13:19 •  Информатика

Напишите программу, которая вычисляет количество цифр числа. используйте функцию.

Ответ:
1234567890859
1234567890859
10.08.2020 18:28
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

function nDigits(n:int64):integer; // если число
begin
  Result:=0;
  if n<0 then n:=-n;
  while n>0 do begin
    Result+=1;
    n:=n div 10
    end
end;

function nDigits(s:string):=s.Length; // если строка

begin
  Writeln(nDigits(1234567890123456)); // 16
  Writeln(nDigits('123456789012345678901234567890')) // 30
end.

Результат
16
30
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?