Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
scapper
31.01.2020 20:09 •
Информатика
На ! 1. написать программу которая будет выводить сумму четных цифр(пока не введете 0). 2.программа выводит количество четных цифр. 3.программу которая будет выводить произведение введенных чисел пока не будет введен 0.
Ответ:
Lane9ig
07.10.2020 08:38
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Sum)
end.
Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
2708
begin
Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Count)
end.
Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
5
begin
Writeln(ReadSeqIntegerWhile(t->t<>0).Aggregate(Biginteger(1),(x,y)->x*y))
end.
Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
-775118121479521866390147967800000
0,0
(0 оценок)
Популярные вопросы: Информатика
GAFur1111
04.11.2021 09:11
по информатике у меня сор поже начислю еще балы за ответы...
rgewwet
28.02.2022 00:48
Цикл в среде программирования составьте пятиугольник...
alionka7
28.02.2022 00:48
Склавиатуры вводится строка. подсчитать сколько раз в нее входит подстрока abc....
surgut186rus
28.04.2023 19:02
Объясните как сделать такую таблицу в Excel?...
toyru556
25.03.2021 02:40
Кетил доктор корабль шторм боль дождь море капитан медведица ветер Осы создерге сойлем на русском...
10alinka01
25.03.2021 02:40
Какие статьи Нантского эдикта которые не устраивали католиков и протестантов? Кратко...
magomedov254
25.03.2021 02:40
7. Назовите отряд насекомых, представители которого по сложности строения и поведению достигли в процессе эволюции наибольшего среди всех насекомых развития. 1) жесткокрылые;...
chuevasasha
01.09.2020 22:38
. В состав какого Тюркского государства входили кыпчаки в VIII-XI ...
Vika17112003
01.09.2021 09:24
Суммативное оценивание за раздел «Тема Рождества в литературе» Подраздел Н.В. Гоголь. «Ночь перед Рождеством»Цель обучения 6.2.1.1 Определять жанр и его признаки (рассказ,...
mihaikl
01.09.2021 09:24
Принадлежность индейца к определённой касте а) определял император б) выбиралась каждым индейцем по собственному желанию в) передавалось по наследству...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Sum)
end.
Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
2708
begin
Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Count)
end.
Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
5
begin
Writeln(ReadSeqIntegerWhile(t->t<>0).Aggregate(Biginteger(1),(x,y)->x*y))
end.
Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
-775118121479521866390147967800000