В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Напишите программу, которая определяет сколько раз встречается максимальное число в и-той последовательности, ограниченная n значением. при этом каждое вводимое число должно храниться в памяти компьютера.

Ответ:
Dashka6969
Dashka6969
07.10.2020 08:10
//Pascal
var
  A: array of integer;
  i, n, MAX, tmpCount: integer;
begin
  write('Введите n = '); read(n);
  SetLength(A, n);
  MAX := 0;
  for i := 0 to n-1 do
  begin
    write('A[', i+1, '] = ');
    read(A[i]);
    if A[i] > MAX then
    begin
      tmpCount := 0;
      MAX := A[i];
      tmpCount := tmpCount + 1;
    end
    else
    if A[i] = MAX then tmpCount := tmpCount + 1;
  end;
  writeln('Максимальное число ',MAX,' встречается ',tmpCount,' раз.'); 
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?