В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Юля5454554
Юля5454554
06.10.2020 07:17 •  Информатика

Составьте программу,которая формирует массив из 11 случайных целых чисел от -10 до 5 и все положительные элементы возводит в квадрат

Ответ:
НезнайкаЛёша
НезнайкаЛёша
10.09.2020 01:53

var

 i, s: integer;

 a: array [1..11] of integer;

begin

 randomize;

 writeln('Chislo   ', 'Kvadrat chisel');

 for i := 1 to 11 do

 begin

   a[i] := Random(16) - 10;

   write(a[i]:4);  

   if (a[i]>0) then writeln(sqr(a[i]):12)

   else writeln('-':12);

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?