В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Cfgcyf
Cfgcyf
01.02.2020 00:27 •  Информатика

Нужно написать программу в pascal'е. описано так. требуется выделить из предложения четвертое слово (слова разделены пробелом).

Ответ:
ащна
ащна
16.08.2020 14:18
Var
  s: string;
  i: integer;
  qp: integer;
  word: string;
begin
writeln('Введите предложение разделяя слова пробелами');
readln(s);
qp:=0;
word:='';
for i:=1 to length(s) do begin
  if s[i]=' ' then
    qp:=qp+1
  else begin
     if qp=3 then word:=word+s[i];
  end;
  if qp=4 then
     break;
end;
if word='' then
  writeln('четвёртое слово не присутствует')
else
  writeln('искомое слово - ', word);

end.

{Пример}
На pascal написана соответствующая программа 
искомое слово - соответствующая
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?