Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
tim2k09
25.11.2021 05:05 •
Информатика
На тему: массив рассортировать числа так,чтобы положительные были справа, отрицательные слева.
Ответ:
OшUb0чkA
07.10.2020 07:26
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
(a.Where(t->t<0)+a.Where(t->t>=0)).Println
end.
Пример
n= 20
42 -10 -32 -31 32 -42 -7 33 -22 5 -45 36 4 26 -23 -28 -13 -44 12 -12
-10 -32 -31 -42 -7 -22 -45 -23 -28 -13 -44 -12 42 32 33 5 36 4 26 12
0,0
(0 оценок)
Популярные вопросы: Информатика
zherukova00
03.08.2020 12:59
Даны координаты точки B(x,y) и радиус окружности R. Центром окружности является начало координат. Определить лежит ли данная точка внутри окружности....
N1R2
20.01.2023 13:51
Написать программу, которая вычисляет среднее арифметическое целых ненулевых элементов введенного с клавиатуры массива размерность 5 элементов. Исходный массив: 23 0 5 0 15 Результат:...
MrLED
24.09.2022 16:55
Составим программу обмена местами двух чисел c=8,d=22. program obmenDan;var c,d:integer;procedure obmen ( a,b:integer);var m:integer;beginm:=a; a:=b; b:=m;writeln(a,b);end;beginwriteln...
Riiiiiii
12.10.2020 23:10
Запишите для исполнителя шестиклассник алгоритм слодения дробей а/б и с/д.Выполните алгоритм для дробей 13/27 и 12/27...
таня44448
08.04.2020 07:53
- - два мини задания тестовых, кто решит правильно накину в подарок ответы я знаю просто перепроверяюсь...
Brandy2005
04.08.2021 05:11
У МЕНЯ СОР Я ПРОСТО НЕ УВЕРЕНА В СВОЕМ ОТВЕТЕ >...
yuliyasecheva
12.03.2023 11:01
7. Какой инструмент позволяет нарисовать произвольнуюфигуру?...
Группа134ПО
16.06.2020 17:29
Расшифруйте: . Метод: простая перестановка ключ: 5 1 8 3 7 4 6 2...
elizamir808
01.12.2020 10:08
Скласти твір-роздум на тему природа мати будь же сином 8-9 речень...
ПростоПапаЮра
19.07.2020 22:44
Котенок господа бога соченение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
(a.Where(t->t<0)+a.Where(t->t>=0)).Println
end.
Пример
n= 20
42 -10 -32 -31 32 -42 -7 33 -22 5 -45 36 4 26 -23 -28 -13 -44 12 -12
-10 -32 -31 -42 -7 -22 -45 -23 -28 -13 -44 -12 42 32 33 5 36 4 26 12