Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
yulyatimonen
01.05.2022 05:58 •
Информатика
Дано 2 массива х(n) и у(m). сколько раз встречается второй элемент второго массива у(m) в первом массиве х(n). (на языке с++)
Ответ:
sking09
07.10.2020 07:13
#include <iostream>
#include <stdlib.h>
using namespace std;
int main() {
int n,m,k=0;
cin >> n >> m;
int x[n], y[m];
srand(time(0));
for (int i = 0; i < n; i++) {
x[i]=rand() % 20;
cout << x[i] << " ";
}
cout <<"\n";
for (int i = 0; i < m; i++) {
y[i]=rand() % 20;
cout << y[i] << " ";
}
cout <<"\n";
for (int i = 0; i < n; i++)
if (x[i] == y[1]) k++;
cout << "k = " << k;
return 0;
}
Пример:
10 8
0 5 14 15 10 5 6 0 18 3
14 5 10 6 2 16 8 17
k = 2
0,0
(0 оценок)
Популярные вопросы: Информатика
11lol22
04.12.2021 10:38
Какой размер у 256 -цветного рисунка?...
anyr04
05.02.2023 20:25
Pascal Ввести одномерный массив, состоящий из n элементов. Найти и вывести на экран номера четных элементов....
alievafatima1
17.02.2022 00:46
В массиве из 15 чисел найти первый отрицательный элемент и его индекс с массиве (пайтон)...
езо1
13.01.2020 06:41
Pascal Ввести одномерный массив, состоящий из т элементов. Найти количество положительных и отрицательных элементов в данном массиве....
sudak7
14.04.2023 18:33
Составить программу удаления из массива последнего нечётного элемента. Массив заполнить случайным образом в диапазоне [-35;50], размерность массива 10 элементов...
linkingday
11.05.2023 17:08
Запишите в нормальной форме число 0.2е+01...
Zhansiya15
24.08.2022 09:29
Почему у одного объекта может быть несколько моделей?...
vafla3121
09.07.2020 19:37
1)объясните из каких оболочек состоит пищеварительный канал и каково его строение? 2)какие функции системы пищеварения?...
nastya19831507
09.07.2020 19:37
Масса пустого бочонка 2 кг него входит 8 кг мёда найди массу 7 таких бочонков наполненных мёдом. двумя...
ivanpanyushkin1
09.07.2020 19:37
Расположи дроби в порядке возрастания. 3/5; 3/4; 3/25; 3/100; 3/15...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <stdlib.h>
using namespace std;
int main() {
int n,m,k=0;
cin >> n >> m;
int x[n], y[m];
srand(time(0));
for (int i = 0; i < n; i++) {
x[i]=rand() % 20;
cout << x[i] << " ";
}
cout <<"\n";
for (int i = 0; i < m; i++) {
y[i]=rand() % 20;
cout << y[i] << " ";
}
cout <<"\n";
for (int i = 0; i < n; i++)
if (x[i] == y[1]) k++;
cout << "k = " << k;
return 0;
}
Пример:
10 8
0 5 14 15 10 5 6 0 18 3
14 5 10 6 2 16 8 17
k = 2