В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
alishraup
alishraup
21.03.2020 15:06 •  Информатика

Решить по икт. 39. составьте программу вычисления длины боковой стороны равнобедренного треугольника, у которого площадь равна s, а длина основания в три раза больше длины высоты, опущенной на него.

Ответ:
ыооп
ыооп
07.10.2020 06:07
Площадь треугольника - s = a*h/2
a = 3*h ⇒ s = 3*h*h/2 ⇒ h = √(2*s/3)
Искомая боковая сторона треугольника - это гипотенуза треугольника со сторонами a/2 (=3*h/2)  и h ⇒ b^2 = (3*h/2)^2+h^2

var s,b,h:real;
begin
readln(s);
h:=sqrt(2*s/3); //s:=3*h*h/2
b:=sqrt(13)*h/2; // b^2 =(3*h/2)^2+h^2
writeln('a = ',3*h:5:2,' h = ',h:5:2);
writeln('b = ',b:5:2);
end.

Пример:
16
a = 9.80 h = 3.27
b = 5.89
0,0(0 оценок)
Ответ:
akhmetova1
akhmetova1
07.10.2020 06:07
На PascalABC.
(20 символов аиыоалокуаикуцлокиуцоауц)
Решить по икт. 39. составьте программу вычисления длины боковой стороны равнобедренного треугольника
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?