В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Настя190411
Настя190411
03.03.2021 20:57 •  Информатика

1.используя функции символьных переменных, написать программу, которая из текста «я хорошая вычислительная машина», получила бы текст «я хорошая машина». 2.используя функции символьных переменных, написать программу получения из слова железнодорожник слов донор, жезл, колено, крокодил.

Ответ:
Elementrix534
Elementrix534
07.10.2020 05:02
Эмм.. Pascal:

var
a, b, c:String;
begin
a := 'Я очень хорошая вычислительная машина';
b := 'Я хороший робот';
writeln('Введите текст ', a, ' и получите текст', b);
readln(c);
if a = c then
begin
writeln(b);
end;
end.

ответ 2:
var
b: array [1..4] of String[9] = ('ДОНОР', 'ЖЕЗЛ', 'КОЛЕНО', 'КРОКОДИЛ');
a, c:String;
i:Integer;
begin
a := 'ЖЕЛЕЗНОДОРОЖНИК';
writeln('Введите текст ', a, ' и получите слова');
for i:= 1 to 4 do
begin
writeln(b[i]);
end;
readln(c);
if a = c then
begin
for i:= 1 to 4 do
begin
writeln(b[i]);
end;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?