В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vasdehinskil
vasdehinskil
31.03.2020 11:04 •  Информатика

Как вывести функцию сравнения двух чисел в паскале с mod и div не используя if? напишите программу, которая считывает два целых положительных числа aa и bb и выводит наибольшее значение из них.

Ответ:
klassklassov
klassklassov
07.10.2020 05:01
var a,b,a1,b1:word;
 begin
writeln('Введите два натуральных числа');
readln(a,b);
a1:=a div b;
 a1:=((a1+2) div (a1+1)) mod 2;
 b1:=(a1+1) mod 2;
writeln('Число ', a*a1+b*b1,' не меньше ',a*b1+b*a1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?