В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
anser8539
anser8539
28.07.2022 15:06 •  Информатика

Напишите программу, которая шифрует тексты следующим образом: исходная строка разбивается на части по 3 символа и эти три символа перемещаются по кругу вправо на одну позицию. если последняя группа символов состоит из 1 или 2 символов, то они остаются неизменными turbo pascal

Ответ:
ghcfgnyhvjt
ghcfgnyhvjt
07.10.2020 03:44
Var s:string; c:char; i:integer;
begin
writeln('Введите строку:');
readln(s);
for i:=0 to length(s) div 3-1 do
 begin
 c:=s[3*i+3];
 s[3*i+3]:=s[3*i+2];
 s[3*i+2]:=s[3*i+1];
 s[3*i+1]:=c;
 end;
writeln(s);
end.

Пример:
Primer, begin, end.iPrrmeb, ieg n,den.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?