В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
oietillokhabiby
oietillokhabiby
04.09.2020 01:35 •  Информатика

Написать программу в которой замена производится по такому правилу: если число делится на 2, то оно умножается на 4. если нет - к нему прибавляется 1. p.s. на паскале. , ! я в информатике полный ноль.

Ответ:
suyargklova
suyargklova
07.10.2020 03:33

//PascalABC.Net v3.1

var n:integer;

begin

  readln(n);

  if n mod 2 = 0 then n:=n*4 else n:=n+1;

  writeln(n);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?