В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Shkolnik1ZloI
Shkolnik1ZloI
04.05.2022 08:52 •  Информатика

Написать программу в с++ натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая это самое число. например, число 6 является совершенным (1+2+3 = 6). найти все совершенные числа, меньшие 100 000.

Ответ:
АниАпельсинка
АниАпельсинка
07.10.2020 03:11
#include <iostream>
using namespace std;

int main(){
    int s;
    for (int i=2; i<=100000; i++){
    s = 1;
    for (int j=2; j<=i/2; j++)
    if (i % j == 0) s+=j;
    if (s == i)
    cout << i << " ";
    }
    return 0;
}

Результат:
6 28 496 8128
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?