В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
atas2
atas2
18.10.2022 18:27 •  Информатика

Надо сдать! написать программу на языке с++ дана последовательность n различных целых чисел. найти сумму ее членов,расположенных между максимальным и минимальным значениями(в сумму включить и оба этих числа).

Ответ:
Алина06072003
Алина06072003
07.10.2020 03:11
#include <iostream>
using namespace std;
int main()
{
 int n,max, min, pos1, pos2, mem, sum;
cin >> n;
pos1 = 0;
pos2 = 0;
int *A = new int[n];
for (int i = 0; i < n; i++)
{
 cin >> A[i];
}
min = A[0];
max = A[0];
for (int i = 0; i < n; i++)
 {
 if (A[i] > max)
 {
  max = A[i];
  pos1 = i;
 }
 if (A[i] < min)
 {
  min = A[i];
  pos2 = i;
 }
}
if (pos2 > pos1)
{
 mem = pos2;
 pos2 = pos1;
 pos1 = mem;
}
sum = 0;
for (pos2; pos2 <= pos1; pos2++)
{
 sum = sum + A[pos2];
}
cout << sum;
system("pause");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?