В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Novalniy2018
Novalniy2018
07.12.2022 00:25 •  Информатика

Напишите программу, решающую следующую . с клавиатуры вводятся количество пятерок, количество четверок и количество троек, полученных учащимся в четверти. на экран необходимо вывести проценты пятерок, четверок и троек от общего количества оценок, полученных учащимся в четверти. очевидно, что сумма процентов пятерок, четверок и троек должна быть равна 100 процентам. при выводе процентов используйте форматированный вывод, задав ширину выводимого результата 6, а количество знаков после десятичной точки — 1.

Ответ:
mordvichev92
mordvichev92
07.10.2020 02:57
var k5,k4,k3,s:integer;
begin
readln(k5,k4,k3);
s:=k5+k4+k3;
writeln('Пятёрок - ',k5/s*100:6:1,' %');
writeln('Четвёрок - ',k4/s*100:6:1,' %');
writeln('Троек - ',k3/s*100:6:1,' %');
end.

Пример:
5 3 2
Пятёрок - 50.0 %
Четвёрок - 30.0 %
Троек - 20.0 %
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?