В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
фскорбин
фскорбин
07.02.2021 21:19 •  Информатика

Напишите программу, которая считает знаки пунктуации в символьной строке. к знакам пунктуации относятся символы из набора «.,; : ! ? ». формат входных данных программа получает на вход символьную строку (длина строки не больше 100 символов). формат выходных данных программа должна вывести общее количество знаков пунктуации во входной строке. примеры входные данные выходные данные hi, guys! 2

Ответ:
vlad007g
vlad007g
07.10.2020 02:40
Var s,p:string; k,i:integer;
begin
readln(s);
p:='.,;:!?';
k:=0;
for i:=1 to length(s) do
 if pos(s[i],p)>0 then k:=k+1;
writeln('k = ',k);
end.

Пример:
Hi, guys!
k = 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?