В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
olyaolya22
olyaolya22
20.09.2021 10:15 •  Информатика

Написать программу поиска минимального значения в массиве, вывести на экран минимальное значение и номер (индекс) этого значения.

Ответ:
Lenaaaa111
Lenaaaa111
20.08.2020 23:43
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var i:=a.IndexMin;
  Writeln('Минимальный элемент ',a[i],' имеет индекс ',i+1)
end.

Пример
n= 15
66 -91 75 27 7 -95 96 48 -35 77 49 71 -13 25 -8
Минимальный элемент -95 имеет индекс 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?