В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Loskinstem5617
Loskinstem5617
15.02.2022 08:48 •  Информатика

Напишите программу на паскале которая решает уравнение ax^2+bx+c=0 используя циклы

Ответ:
Никольнейв
Никольнейв
07.10.2020 01:42
Для Одри можно и покороче ))
Только для случая одного корня печатается 2 одинаковых. Так тоже можно

Var a,b,c,d: real;
Begin
WriteLn('Решение ax^2 + bx +c = 0');
WriteLn('Введите a b с '); ReadLn (a, b, c);
if a=0 then WriteLn('Это не квадратное уравнение. Решайте его сами! ')
else
begin
d:=b*b-4*a*c;
if d<0 then Writeln('Нет действительных корней')
else WriteLn('корни: ', (-b+Sqrt(d))/(2*a),' и ', (-b-Sqrt(d))/(2*a) );
end;
ReadLn
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?