В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DavtynGalia
DavtynGalia
16.01.2023 10:18 •  Информатика

Вычислить сумму и произведение 1, 2, . нужно составить программу.

Ответ:
Саня1585
Саня1585
07.10.2020 00:46

#include <iostream>

using namespace std;

int sum(int n, bool o)

{

if (n == 0 && o)

return 0;

if (n == 1)

return 1;

if (o)

return sum(n - 1, 1) + n;

else

return sum(n - 1, 0) * n;

}

int main()

{

int n;

cin >> n;

cout << sum(n, 1) << "\n"

<< sum(n, 0);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?