В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
fFlower337
fFlower337
17.01.2020 09:18 •  Информатика

Составьте программу, которая определяет, сколько слагаемых должно быть в сумме 1+2+3+4+ чтобы сумма оказалась больше заданного числа n

Ответ:
adrien3000
adrien3000
07.10.2020 00:23
Var n, s, k: integer;
begin
readln(n);
s:=0; k:=0;
while s<n do
 begin
 k:=k+1;
 s:=s+k;
 end;
writeln('k = ',k);
end.

Пример:
60
k = 11
0,0(0 оценок)
Ответ:
помогите1178
помогите1178
07.10.2020 00:23
Var i,s,n: Integer;
begin
readln(n);
for i := 1 to 10000 do begin
s := s + i;
if s > n then
begin
writeln(s);
halt;
end;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?