Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Алена1563795
07.07.2020 04:01 •
Информатика
Паскаль составить программу отсортировать 4 столбец двумерного массива по возрастанию (8 на 8)
Ответ:
Koko1324
03.08.2020 21:29
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(8,8,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
a.SetCol(3,a.Col(3).OrderBy(x->x).ToArray);
Writeln('*** Полученный массив ***'); a.Println(4)
end.
Пример
*** Исходный массив ***
77 68 79 -85 30 -28 -11 85
-52 -62 -94 -30 -82 31 -16 -80
-97 -95 84 -62 -53 5 68 -23
53 7 38 10 -88 -66 98 85
-99 -31 -6 71 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 -95 73 -55 -7 -27
99 3 -39 -77 33 78 73 -85
*** Полученный массив ***
77 68 79 -95 30 -28 -11 85
-52 -62 -94 -85 -82 31 -16 -80
-97 -95 84 -77 -53 5 68 -23
53 7 38 -62 -88 -66 98 85
-99 -31 -6 -30 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 10 73 -55 -7 -27
99 3 -39 71 33 78 73 -85
0,0
(0 оценок)
Популярные вопросы: Информатика
teorem
06.09.2021 16:03
Книга набранная компьютере содержит 1024 страницы на каждой странице 64 строки в каждой строке 25 символов определите информационный объём книги в мбит в одной из кодировок...
titan9064
06.09.2021 16:03
Сравните 1)250 байт и 0,25 кбайт,2)1 мбайт и 1000 кбайт,3)8192 бита и 1 кбайт...
роги1
26.02.2021 21:10
Переведите число 456 из восьмеричной системы счисления в десятичную систему...
999Roman999999991
26.02.2021 21:10
Спримером по паскалю: sqrt (15 div 7 + 34 mod 9). плс...
Xela936
06.06.2023 21:27
Дан текст. определить количество букв к . по правилам машинописи после знаков препинания этих ошибок в тексте, полученную после исправления строку показать на экране....
sofyabelik
24.04.2020 15:03
Написать программу на языке паскаль(abc) для решения простого линейного уравнения...
ggggeorgiyggg
19.09.2021 14:39
Электронная таблица по информатике ms excel используя набор данных крупнейшие промышленные корпорации (приложение, №9), построить столбчатую диаграмму, отражающую оборот...
Kotyaty
09.04.2023 03:51
8класс 70 .10. в магазине побывало 36 человек. известно, что они купил 10 планшетов, 15 смартфонов, 23 телевизора. 7 из них купило и планшет, и смартфон, 15 человек...
adelinanurgazi
11.11.2020 08:38
Сделайте это в паскале авс. записать файл: 5 одинаковых целых чисел. 7 любых чисел сумму 10 любых чисел произведение 10 любых чисел...
Ainur0529
25.04.2022 11:40
Найдите х 12(2х)-12(х)=6(10) в скобках это система счисления...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(8,8,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
a.SetCol(3,a.Col(3).OrderBy(x->x).ToArray);
Writeln('*** Полученный массив ***'); a.Println(4)
end.
Пример
*** Исходный массив ***
77 68 79 -85 30 -28 -11 85
-52 -62 -94 -30 -82 31 -16 -80
-97 -95 84 -62 -53 5 68 -23
53 7 38 10 -88 -66 98 85
-99 -31 -6 71 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 -95 73 -55 -7 -27
99 3 -39 -77 33 78 73 -85
*** Полученный массив ***
77 68 79 -95 30 -28 -11 85
-52 -62 -94 -85 -82 31 -16 -80
-97 -95 84 -77 -53 5 68 -23
53 7 38 -62 -88 -66 98 85
-99 -31 -6 -30 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 10 73 -55 -7 -27
99 3 -39 71 33 78 73 -85