В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Gendalf1875
Gendalf1875
30.04.2021 20:25 •  Информатика

Даны три целых числа.напишите программу ,подсчитывающую сумму тех чисел ,которые являются нечетными

Ответ:
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadInteger3('Введите три целых числа:');
  var s:=0;
  if a.IsOdd then s+=a;
  if b.IsOdd then s+=b;
  if c.IsOdd then s+=c;
  Writeln('сумма нечетных равна ',s)
end.

Пример
Введите три целых числа: 345423 -324342 1231
сумма нечетных равна 346654
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?