В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Vania161
Vania161
23.02.2023 00:27 •  Информатика

Сложные условия ветвления ! напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. пример: введите три числа: 5 5 5 все числа одинаковые. пример: введите три числа: 5 7 5 два числа одинаковые. пример: введите три числа: 5 7 8 нет одинаковых чисел.

Ответ:
MatveiKnyaz2005
MatveiKnyaz2005
06.10.2020 23:14
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  case ReadSeqInteger('Введите три целых числа:',3).Distinct.Count of
  3:Writeln('Нет одинаковых чисел');
  2:Writeln('Два числа одинаковые');
  else Writeln('Все числа одинаковые')
  end
end.

Примеры
Введите три целых числа: 5 5 5
Все числа одинаковые

Введите три целых числа: 5 7 5
Два числа одинаковые

Введите три целых числа: 5 7 8
Нет одинаковых чисел
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?